Forums

Overrun Stack Based Buffer

Quick find code: 409-410-107-66006192

Trics
Mar Member 2018

Trics

Posts: 176Iron Posts by user Forum Profile RuneMetrics Profile
Hello, looking for some help.

So I've been experiencing the game crash error "Stack based buffer, malicious user could gain access" for about a month now, maybe 2. It will happen at random and is very annoying. Sometimes will happen 2 times within like 15 minutes and that makes me want to pull my hair out.

I've uninstalled and reinstalled the client, let the cache download (although it stops at 4.9gb), run as administrator, the only thing I haven't tried yet is to try and run it in windows 7 compatibility mode. But it still happens.

I have a fairly new laptop (bought in january) with a i7 processor, 1060 gpu, 16gb ram. So I don't think it's a performance issue. (Or a hardware issue for that matter, as the laptop is very new and I have not damaged it, and would like to believe the manufacturer didn't send me a faulty laptop[but yes I know it's possible.. still don't think it's the issue here, as I ONLY have issues with rs3 nxt client])

I've seen others recently post about this issue as well. I would just like to see it resolved. It makes the game feel unplayable when I have to worry about a potential crash every hour. And that sucks because I enjoy the game and I'm paying to play it.
Respite
-
The Grim Reaper

18-Apr-2018 17:04:19

L0NE DRUID
Jan Gold Premier Club Member 2011

L0NE DRUID

Posts: 8,315Rune Posts by user Forum Profile RuneMetrics Profile
Hey
Trics
,

The error itself is usually linked to old out of date drivers that need updating, while the machine may be new, manufacturers like Nvidia and AMD often push driver patches. What you need to do is find the GPU in your machine and then un-install the current driver and install the latest one from the Nvidia website.

If you have a laptop with the 1060, make sure the 1060 is being used as the primary GPU and not the intel one. Keep in mind the Intel GPU will also need to be updated as laptops have two GPU's usually.

To make 1060 the default GPU for Runescape, follow my steps below.

1) Firstly you need to open up your Nvidia control Panel, which can be found either by searching for it in your start bar, or right clicking a blank space on your desktop (Not a Icon) then click "Nvidia Control Panel"

2) After your in the Control Panel look on the left hand side you will see a "3D Settings Tab" in that tab click on the "Manage 3D settings"

3) Once you are in the "Manage 3D settings you will be in the "Global Settings Tab" in these settings you will see a drop down for "Preferred Graphics Processor" in this section drop down the selector and click your Nvidia graphics card and not your CPU then hit apply which will be on the bottom of your screen.

4) Finally look on the left hand side tabs again and click on the "Set PhysX Configuration" and again make sure that's set to your Nvidia graphics card and hit apply and launch the client, have a look at my images below for the steps.

Step 1


Step 2


I hope this information has been of help to you, feel free to update me on the matter by reposting on this thread :).
A Jagex Verfied Community Helper
Leader of Zealmania
*
A Runescape player since 2005
|
@JagexHelpL0ne

Tech Issues? Click Me!

22-Apr-2018 18:04:10

Quick find code: 409-410-107-66006192Back to Top