Forums

Firefox not supporting JavaThread is lockedThread is sticky

Quick find code: 409-410-959-65888830

Mod Cake

Mod Cake

Jagex Moderator Forum Profile Posts by user
Attention all Firefox users!

Firefox is no longer supporting Java, so those who are using the latest version of Firefox will no longer be able to play RuneScape.

People using anything earlier than Firefox 52 should still be able to play on RuneScape, but this is not advised as old versions of browsers can be prone to malware/viruses, so are rather insecure.

Those effected by this should look to download the client or play on Internet Explorer instead. :)

Of course if you have any questions or need any advice, you're more than welcome to contact us directly or post in the Community Tech Help forums. :D

Happy 'Scaping!
Mod Cake

Customer Support

Professional Bank Stander

07-Mar-2017 20:16:31 - Last edited on 07-Mar-2017 20:53:17 by Mod Cake

Quick find code: 409-410-959-65888830Back to Top