Forums

Pre-Loading Shaders?

Quick find code: 409-410-133-66110067

Half Amazing

Half Amazing

Posts: 184Iron Posts by user Forum Profile RuneMetrics Profile
Hi all!

Recently just had the motivation to play the game again, however I'm experiencing a bit of annoyance whilst loading up the client launcher.
There's this loading thing on the top left of the client which states (Pre-Loading Shaders...%)..
The problem is that it takes quite awhile for it to load sometimes nearly up to two minutes.. thought I don't mind waiting, but would prefer if it was sped up.

Is there any chance I can speed that up or remove it?

Thanks,

Half

10-Jul-2019 22:47:07

Moneybucks
Nov Gold Premier Club Member 2018

Moneybucks

Posts: 7,835Rune Posts by user Forum Profile RuneMetrics Profile
You can generally ignore that; you don't need to wait for it, I think. I seem to recall reading that had to do with loading graphical assets from the cache into memory, but not sure whether that was GPU memory or system memory. Either way, I suspect there's not much you can do to make it any faster, other than a physical upgrade. Assuming you're not fully consuming one or the other.

Assuming that you're experiencing some kind of performance issue, more important in terms of performance impact is to ensure your game cache is fully built.

You can see the total data in the cache if you run the "displayfps" developer console command - the maximum can vary, but mine is about 8GB as an indicative amount.
Moneybucks

11-Jul-2019 13:37:39 - Last edited on 11-Jul-2019 16:58:10 by Moneybucks

Half Amazing

Half Amazing

Posts: 184Iron Posts by user Forum Profile RuneMetrics Profile
Hey!

thanks for the reply, but even if I don't wait for it and log in straight away - my game just slows down making me lag and unable to move around freely for atleast another three minutes. It's bearable yes, however I do want to get moving straight away haha

Half

13-Jul-2019 22:32:24

Redbull
Aug Member 2019

Redbull

Posts: 8Bronze Posts by user Forum Profile RuneMetrics Profile
I have the same issue.. when the client starts the "Pre-Loading shaders ...x%" starts.. and it takes aprox 5 minutes, and if I some how manage to log in, it lags as crazy..
I deleted the caches from the folders, but that only made it good one time..
The problem is EVERY time I close and open the rs client, lags like hell for around 5 minutes..

02-Sep-2019 08:18:45

Quick find code: 409-410-133-66110067Back to Top