Forums

cant get rs3 to work.

Quick find code: 409-410-172-66115446

Pinguicula

Pinguicula

Posts: 9,475Rune Posts by user Forum Profile RuneMetrics Profile
I thought Hmm would be in here to answer your questions but I haven't seen him, yet, so ...

Jagex's instructions for installing the client don't work in Ubuntu 19. In the past I posted instructions for older versions of Ubuntu that worked but weren't ideal and it looks like you might have tried using one of my posts to get to the point of missing libcurl.so.4. For Ubuntu 19 don't do that. Use the Flatpak or Hmm's Snap instead.

Flatpak:
https://flathub.org/apps/details/com.jagex.RuneScape


Snap:
https://snapcraft.io/rslauncher


Neither are officially provided by Jagex but there haven't been any issues with using them and they do install the official clients. Each one fixes the issues with installing the client which are caused by Jagex not updating their DEB package for the NXT client.

10-Aug-2019 20:18:12

Hmm
Jan Gold Premier Club Member 2016

Hmm

Posts: 12,279Opal Posts by user Forum Profile RuneMetrics Profile
Every supported Ubuntu flavour should support snap by default, barring Lubuntu 16.04 and 18.04, but even Lubuntu has it by default for 18.10+

as such,
snap install rslauncher

should be all you need on basically any Ubuntu official flavour, though Snapcraft and Flathub have instructions for a lot of variety's in distros, so I'm hoping OP managed to figure it out from the websites themselves

I decided to have a little forum vacation the other day for a few weeks so I won't be around much, thanks for covering here though Ping :)

11-Aug-2019 14:48:42

Quick find code: 409-410-172-66115446Back to Top