Forums

Problens with Rune in Linux

Quick find code: 409-410-95-66083961

mederim

mederim

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
I installed Rune in my desktop, I use Linux Mint. I am of community PT-BR and I have used this command for install:

sudo -s -- << EOF
wget -O - https://content.runescape.com/downloads/ubuntu/runescape.gpg.key | apt-key add -
mkdir -p /etc/apt/sources.list.d
echo "deb https://content.runescape.com/downloads/ubuntu trusty non-free" > /etc/apt/sources.list.d/runescape.list
apt-get update
apt-get install -y runescape-launcher
EOF


And I have success, but recently this message has appeared in the Update Manager of Linux Mint:

https://i.imgur.com/xW8VVH7.png

What should I do?

From what I understand the updates are not being made, why repositories are wrong.

Since now, I appreciate the help!

17-Feb-2019 16:29:33 - Last edited on 17-Feb-2019 16:33:20 by mederim

Pinguicula

Pinguicula

Posts: 9,347Rune Posts by user Forum Profile RuneMetrics Profile
Jagex is still using a SHA-1 based signature and your version of Linux Mint requires a signature based on something better than SHA-1 such as SHA-256. Unfortunately you will see that error message if you are using a current version of Linux Mint and Jagex's repository until Jagex's updates their signature. Your operating system might be updating OK anyway. However, if you want to bypass the signature check you can do

sudo sh -c 'echo "deb [trusted=yes] https://content.runescape.com/downloads/ubuntu trusty non-free" > /etc/apt/sources.list.d/runescape.list'


so that regardless of the signature issue the repository will be trusted. You might still see a message about the invalid signature but updates will complete. Unfortunately doing this basically disables a security feature of Linux.

I am unsure about what version of Linux Mint you have. You typed that you used Jagex's instructions to install the client but Jagex's instructions don't work with the current version of Linux Mint. I thought maybe you have an older version of Linux Mint. However a version of Linux Mint that is old enough to work with Jagex's instructions for installing the client wouldn't have a problem with Jagex's SHA-1 signature.

17-Feb-2019 20:43:35

Devonon
May Gold Premier Club Member 2016

Devonon

Posts: 222Silver Posts by user Forum Profile RuneMetrics Profile
Sudo su

echo "deb http://archive.ubuntu.com/ubuntu/ trusty main" > /etc/apt/sources.list.d/ubuntu_14.04_aka_trusty.temp.list
apt-get update

apt-get -y install libglew1.10 libpng12-0
rm /etc/apt/sources.list.d/ubuntu_14.04_aka_trusty.temp.list

apt-get -y install libcurl3

wget -O - https://content.runescape.com/downloads/ubuntu/runescape.gpg.key | apt-key add -
echo "deb [trusted=yes] https://content.runescape.com/downloads/ubuntu trusty non-free" > /etc/apt/sources.list.d/runescape.list

apt-get update

apt-get install -y runescape-launcher



this is my install method to force the unsgined key cause they are poop at updating the launcher the game its self works but the launcher gpg key is sheit

the game launcher requires out of date stuff in ubuntu mint is a offshoot of ubuntu so libglweb1.1 and libnpng 12 and libcurl 3 are required for the launcher and game
5277K/10000k barrels of monkeys

21-Feb-2019 22:34:04 - Last edited on 21-Feb-2019 22:37:58 by Devonon

Quick find code: 409-410-95-66083961Back to Top