Forums

Can't Access App?Thread is sticky

Quick find code: 429-430-674-66017547

of 10
Albert Roe
Jun Member 2017

Albert Roe

Posts: 10Bronze Posts by user Forum Profile RuneMetrics Profile
Tantza said:
Tantza said:
Could the following issue be handled by mods as soon as possible? It's urgent and affecting thousands of OSRS players using mobile, there's being made more and more topics about this to these forums right now.


I got Android 7.1.1 with 2GB RAM (Samsung Galaxy J5 2016) and been using OSRS (Beta) since 5.7.2018 already. Now after the update last thursday (22.11), it started downloading the client n stopped with the error message: "Old School Runescape has encountered a problem. Your client needs updating. Opening store page..."

It didn't open the page and now when trying to search for "Old School Runescape" in Play Store, it's nowhere to be found. Tried deleting the beta version and search again, no such a luck.

Only way I found it, was through the browser and there it kept telling me that my device is not compatible with this version and wont let me download it, even though I have the latest Android updates (7.1.1, and it SHOULD BE working on 5.0 or newer) and was working perfectly for 4,5months before the recent update, on last thursday 22.11.


Neriphyra replied to my topic last weekend, saying that this issue will be shared to the team to look into, but no other reactions / Jmod replies on this big issue yet, that is blocking probably thousands of eligible users from downloading / using mobile.

Please, could this issue be handled Asap?
Appreciated. :)


It's been almost 2 weeks since the Osrs update (22.11) that made thousands of eligible player unable to download, update or play OSRS Mobile. I know that CM Neriphyra stated she reported this issue to the team, but still no updates where we are going on in it at this moment. Could we please get some information about it?


When you wrote this reply it was 7 days since Neriphyra replied lol. I am sure they are working on it.

05-Dec-2018 09:12:20

Cake au Noob
Dec Member 2017

Cake au Noob

Posts: 66Iron Posts by user Forum Profile RuneMetrics Profile
Hi, I've been playing on the beta with no issues until a couple of weeks ago when an update came through I was unable to get hold of the update. Google Play says the app is no longer compatible with my device.
I'm using the same device as I was before and have tried updating my android version but it hasn't helped.
I'm using a Samsung Galaxy J5 running Android 7.1.1
I am unable to download updates or find the app by searching in Google Play unless I access it by booting up the Oldschool Runescape Mobile app and launching Google Play from the update prompt, though I cannot update and it is no longer updating automatically.
Please help!

28-Dec-2018 16:41:53

Littledoom

Littledoom

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
Device: iPad 4th Generation
Manufacturer: Apple
Operating System: iOS 10.3.3
Internet Connection: Wi-Fi
Connection Speed/Provider: 1 gb/s - Suddenlink

I'm able to view the Runescape mobile app in the appstore. When I download it, it tells me that my device is not compatible with the latest version of the app. Even though the app is supposed to support devices at iOS 10.0+. The appstore prompts me to download the latest compatible version of the app. After downloading this version (Version 172), I try to launch the app. The app launches to a solid black screen, holding at that screen for about 20 seconds, and then crashes. I've seen other people on both iPad and Android devices having this same issue, as well as not being able to see the app in their respective appstore at all.

After contacting customer support, I was told that the app was optimized for smartphones and not tablets. And that I would most likely just continue to have issues. If this is really the case, please let me know now. I understand that you guys want to prioritize smartphone optimization because everybody has a smartphone and not everybody has a tablet. But you have to understand, functionally, this game is much better on a tablet, as the majority of smartphones are too small to comfortably use the app. You guys are losing out on a lot of money in the tablet community.

This has been mentioned in other threads and a few times in this one, but we're reaching a point where people are getting really upset. I think more than anything, we would just like some kind of response. Even just a "The problem has been acknowledged and we are working on it". We've had zero communication.

05-Jan-2019 08:36:42

DudeHUN

DudeHUN

Posts: 1Bronze Posts by user Forum Profile RuneMetrics Profile
I have tried to install the OSRS app on my Huawei P8 Lite (Android 6.0, 2 GB ram). However, my device should be compatible, google says my device is incompatible with the app. Is this issue present for anyone else or is it just me? Other, maybe useful information about the phone:
Model number: ALE-L21
Build number: ALEL21C02B898
Android version: 6.0
CPU: 8 cores, 1.2 GHz
RAM: 2 GB
Kernel v.: 3.10.86-ga8f7cac
Although, the app runs perfectly if I download a raw .apk file from a site, like apkmirror, I still cannot install it from google and I don't want to download a new apk file after every update, as it's a nuisance and redistributed apk files may contain virus or miner or may join my device to a botnet.

30-Jan-2019 09:43:30

Tantza
Jun Member 2017

Tantza

Posts: 780Gold Posts by user Forum Profile RuneMetrics Profile
Could the following issue be handled by mods as soon as possible? It's urgent and affecting thousands of OSRS players using mobile, there's being made more and more topics about this to these forums right now.


I got Android 7.1.1 with 2GB RAM (Samsung Galaxy J5 2016) and been using OSRS (Beta) since 5.7.2018 already. Now after the update last thursday (22.11), it started downloading the client n stopped with the error message: "Old School Runescape has encountered a problem. Your client needs updating. Opening store page..."

It didn't open the page and now when trying to search for "Old School Runescape" in Play Store, it's nowhere to be found. Tried deleting the beta version and search again, no such a luck.

Only way I found it, was through the browser and there it kept telling me that my device is not compatible with this version and wont let me download it, even though I have the latest Android updates (7.1.1, and it SHOULD BE working on 5.0 or newer) and was working perfectly for 4,5months before the update, on 22.11.

Forum mod Neriphyra replied here 2m+ saying that this issue will be shared to the team to look into, but no other reactions / Jmod replies on this big issue yet, that is blocking probably thousands of eligible users from downloading / using mobile.

Please, could this issue be handled Asap?

05-Feb-2019 19:39:42

Tantza
Jun Member 2017

Tantza

Posts: 780Gold Posts by user Forum Profile RuneMetrics Profile
HOX HOX! It's been already 2,5 months since (22.11.2018) in game update that made this error occur, and STILL there's no update or reply to the players how this thing is being handled, I don't know what to do right now to get this thing fixed? To be honest, this is completely unacceptable. Forum mod Neriphyra or any other forum/J mod, please react and reply to this please, this is just ridiculous how this issue is being handled by the staff, it has been completely ignored by the staff even after this long time.

Thousands of players (including me and so many others) are feeling helpess in here, and it's no longer accepted that we would only get reply here that "This issue is being under investigation by the team", I insist that we will get solution to this problem AS SOON AS POSSIBLE, because this is not how to treat paying members of this game. I don't think there's much more to say, just fix it AND reply here how AND WHEN this issue is being handled.

Best regards,

Tantza, on behalf of thousands of other OSRS Mobile users
.

05-Feb-2019 19:40:00

Quick find code: 429-430-674-66017547Back to Top