Forums

Linux NXT client update.

Quick find code: 16-17-449-66022959

Stella Gazer
Oct Member 2018

Stella Gazer

Posts: 62Iron Posts by user Forum Profile RuneMetrics Profile
Dear jagex,
The linux client hasn't been updated for nearly 6 years.

Nobody is able to install the client anymore on linux distritbutions.

Its filled with bugs.

You are losing player base because of this.

I can't play the game anymore.

30-Jun-2018 13:24:11

Tagakhlo
Sep Gold Premier Club Member 2014

Tagakhlo

Posts: 913Gold Posts by user Forum Profile RuneMetrics Profile
Oh dear, that's bad. There used to be a Linux version of the Java client, but now that they're encouraging people to use NXT, I wasn't able to find that the last time I looked.

Does the Windows NXT client work under Wine or ReactOS by any chance?

30-Jun-2018 21:12:57

Bepsmum
Oct Member 2011

Bepsmum

Posts: 94Iron Posts by user Forum Profile RuneMetrics Profile
Is there an update on this pls? I'm running Mint and cannot install the NXT for Linus. If it helps, here's the issues:
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'
W: GPG error: https://content.runescape.com/downloads/ubuntu trusty InRelease: The following signatures were invalid: AAC9264309E4D717441DB9527373B12CE03BEB4B
E: The repository 'https://content.runescape.com/downloads/ubuntu trusty InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package runescape-launcher

As with the OP, I don't want the Windows client thanks.

11-Dec-2018 18:00:06

Bepsmum
Oct Member 2011

Bepsmum

Posts: 94Iron Posts by user Forum Profile RuneMetrics Profile
So, I'm running a standard Ubuntu install now on a different partition from the Mint install. I still cannot get Runescape NXT to install. Can you please help : I've been a member for eons, but can't play now.

W:GPG error: https://content.runescape.com/downloads/ubuntu trusty InRelease: The following signatures were invalid: AAC9264309E4D717441DB9527373B12CE03BEB4B, E:The repository 'https://content.runescape.com/downloads/ubuntu trusty InRelease' is not signed., W:Updating from such a repository can't be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., E:Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi', E:Sub-process returned an error code

12-Dec-2018 21:04:55

CM Nick

CM Nick

Local Moderator Posts: 1,325Mithril Posts by user Forum Profile RuneMetrics Profile
Bepsmum said:
So, I'm running a standard Ubuntu install now on a different partition from the Mint install. I still cannot get Runescape NXT to install. Can you please help : I've been a member for eons, but can't play now.


Hey Bepsmum!

As Tren helpfully pointed out, there's another thread you can post this in that will probably be much more helpful to you!

Tren said:
@ Bepsmum - You might want to post on the Community: Linux Support 2.0 sticky in the Community Led Technical Support Forum.


Cheers!

12-Dec-2018 21:42:43

Quick find code: 16-17-449-66022959Back to Top