Forums

Updating the Linux download

Quick find code: 278-279-423-66111097

of 2
Matagui

Matagui

Posts: 79Iron Posts by user Forum Profile RuneMetrics Profile
I don't remember which thread on the forum led me to following page but it saved my day.
https://snapcraft.io/install/rslauncher/ubuntu#install
There is still bad mem leak but playable enough. The app eats up more than 80% of 7.7G mem.
But before installing snap app it was more than 95%.

18-Sep-2019 18:35:46

Hmm
Jan Gold Premier Club Member 2016

Hmm

Posts: 12,279Opal Posts by user Forum Profile RuneMetrics Profile
Hi Matagui,

all I can really suggest is that the graphics drivers and kernel version you have are probably the single likeliest cause of issues with RS acting how it is. It's not impossible for the game to have a memory leak, but nothing suggests that this is a more common issue. If you're using NVidia cards, ensure you're using the proprietary driver (check the software sources tool in Ubuntu to get that up and running). Otherwise, it might be worth upgrading to 19.04 and trying to see if that gives you any improvements, 19.10 is also just around the corner and should be out on the 17th of October, this might improve your situation a lot also.

Generally speaking, the Snap enforces consistency of a lot of components RS would usually use from the host system by replacing them with it's own, so these components are pretty well tested and don't seem to have any issues. The bits outside of the snap that are fetched from the core OS are thus more likely to be the problem.

If you installed the original release of Ubuntu 18.04 and not one of the newer point releases (E.G, 18.04.3), you might benefit from running this in the terminal

sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

which upgrades a lot of the core system libraries (kernel/graphics stack) to newer versions from the newer Ubuntu releases. This can substantially improve hardware support, but it's somewhat likely you already have these to begin with.

19-Sep-2019 02:25:30 - Last edited on 19-Sep-2019 02:28:10 by Hmm

Matagui

Matagui

Posts: 79Iron Posts by user Forum Profile RuneMetrics Profile
I tried that line of command and it looked improved leakage. When I start up the game it mem usage was around 75% but it keeps rising and when I killed Agoroth and cracked a black pearl the game froze. I could barely hit Alt key and logged out from OS. It doesn't respond for 30 sec but finally I could login again so I didn't need to push power button forcing restart.
I'll try coming OS update. Thank you for your kind advice. I really appreciate.

19-Sep-2019 04:56:22 - Last edited on 22-Sep-2019 11:11:31 by Matagui

Louiellen

Louiellen

Forum Moderator Posts: 51,052Emerald Posts by user Forum Profile RuneMetrics Profile
Matagui said:
Wow! That commans worked! Thank you so much ForTimeBeing.
I'm on Ubuntu 18.04 LTS.


It may work, but not optimal. It is a Frankenstein install (as in you're "on your own" configuration), as you let packages not designed for Bionic to be downloaded to your system.

19-Sep-2019 10:11:02

Quick find code: 278-279-423-66111097Back to Top