Forums

Random OSRS lagging/disconnectThread is locked

Quick find code: 409-410-163-66044940

of 2
Sir Taryn
Sep Member 2018

Sir Taryn

Posts: 5Bronze Posts by user Forum Profile RuneMetrics Profile
Over the last 2-3 days, my game has had these moments every few minutes where the entire game freezes for 2-5 seconds. Sometimes I even get the "connection lost - attempting to reestablish" error at the top of the screen and it is random if it fixes itself or forces me to log in once again.

I had tried with the official Runescape client, OSBuddy, and also Runelite. They all had these "lag" issues for me.

My internet has always been stable and my PC is also not a problem from a hardware point of view.

I have tried various troubleshooting tips/methods and none seem to help.

Would it be possible that it is simply problematic servers/worlds over the last few days?

I'm looking for suggestions and would appreciate any help :)

15-Sep-2018 14:05:14

Inf Slayer
Aug Member 2018

Inf Slayer

Posts: 222Silver Posts by user Forum Profile RuneMetrics Profile
im having the same problem and its getting worse cuz i just got disconnected from the server and i had to log in back again .. and ofc if i die cuz of that and lose stuff jagex wont take any responsibility and get me my stuff back just as when i got hacked 2 weeks ago and they said we dont return stolen items .. great job by jagex on making me love the game more everyday

15-Sep-2018 16:18:34

Marc II NL
Aug Member 2018

Marc II NL

Posts: 1,867Mithril Posts by user Forum Profile RuneMetrics Profile
Yes, I have that too since Friday. And it is on there side not my side here everything works fine.
BTW im on old school Runscape.

16-Sep-2018 08:45:59 - Last edited on 16-Sep-2018 08:48:56 by Marc II NL

SoleilxX
Oct Member 2018

SoleilxX

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
YESSS! Here I thought I was the only one. My Ethernet connection is perfectly fine. Browsing, gaming with numerous games (World of Warcraft, Counter-Strike, etc) that require an absolute perfect connection to be able to play, and yet just standing in the GE (on old School Runescape Client) I get randomly disconnected every 1-3 minutes for about 5-10 seconds.

I can say I'm SCARED to even Chin at MM caves knowing I will die if this happens...

Believe me I've tried just about everything to try and resolve this.. Perhaps it's the servers themselves??? OR maybe I need to modify something on my computer( Windows10)??

Put it this way, I've played mobile and NOT ONCE has this happened.

Please let's BUMP this thread.

BUMP
BUMP
BUMP

18-Oct-2018 18:10:46 - Last edited on 18-Oct-2018 19:24:17 by SoleilxX

KSC
Apr Member 2016

KSC

Posts: 55Iron Posts by user Forum Profile RuneMetrics Profile
I suggest creating a batch (.bat) file with this code in it.

@ECHO off

SET worlds=1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,124

FOR %%i IN (%worlds%) DO (
Echo | SET /p=World %%i
FOR /F "tokens=5" %%a IN ('Ping oldschool%%i.runescape.com -n 1 ^| FIND "time="') DO Echo %%a
)
PAUSE


Save the file as Worlds.bat and run it, whenever you disconnect in RS run the file and see what your ping times are, also if you are Windows 10 (Redstone5, Build Number: 17763, Verison number 1809) which is the latest build you may have to update your ethernet/wifi drivers.

If else fails, I suggest looking at your task manager and viewing programs by Network and ofcourse updating your Java (for whatever reasons).

27-Oct-2018 23:18:44 - Last edited on 27-Oct-2018 23:22:31 by KSC

Quick find code: 409-410-163-66044940Back to Top