Forums

Major text glitch, Java client

Quick find code: 409-410-976-66116973

of 2
lost ravens
Jun Member 2019

lost ravens

Posts: 861Gold Posts by user Forum Profile RuneMetrics Profile
Hello,

I have been using the old Java client to play RS for some time now, as my PC is too old to support the newer version. Things have been working fine until today. I have loaded my RS client and all the text was jumbled up. I could not make sense of any of the writing. Was able to log in, but the same issue appears in game as well. Everything seems to be working fine, except that anything that has text or numbers is all jumbled up and impossible to read. Can't even enter my bank pin, as the numbers are incomprehensible. It looks like an alien language.

Any advice on what might be the issue and what I can do?

So far I have tried the following with no results: reinstalled old Java client, deleted all Jagex caches, changed game graphics to minimum.

Here are my specs:

Game Version (OSRS/RS3): RS3
Type of client used (Java/NXT/Mobile/3rd Party): Java
Operating System (Windows/Mac OS/Linux or Android/iOS Version): Windows xp
Laptop/Desktop/Phone/Tablet: desktop

Processor: Pentium (R) Dual-Core CPU E5400 @ 2.70GHz
Graphics Card: Intel(R) G41 Express Chipset
RAM: 3.20 GB

Edit: Solution seems to be to switch from DirectX on the Java client and use either OpenGL or safe mode for now.

20-Aug-2019 00:21:07 - Last edited on 20-Aug-2019 21:40:44 by lost ravens

Moneybucks
Nov Gold Premier Club Member 2018

Moneybucks

Posts: 7,839Rune Posts by user Forum Profile RuneMetrics Profile
Could be a game bug, as the update earlier today fucked up the legacy client fairly well. But if it was, I'd expect more people to be experiencing it.

Screenshot?

EDIT
Some posts on the thread below that seem to bear similarities to your issue - given that, I'm inclined to think it is a game bug - send a bug report from ingame (if you're able).

Quick find code: 409-410-258-66116858
Moneybucks

20-Aug-2019 00:50:43 - Last edited on 20-Aug-2019 00:52:33 by Moneybucks

lost ravens
Jun Member 2019

lost ravens

Posts: 861Gold Posts by user Forum Profile RuneMetrics Profile
Thanks for the reply. I will try to report as bug but it is very difficult as I cannot see the text. I am happy to hear that this is affecting other Java client users. I know I have to upgrade my PC, will do that next year, but for now I need a short term solution so I can play lol.

@Wolfiez: Can you describe to me more how to open the client in safe mode? I tried holding down "s" while clicking on client, nothing different happens.

20-Aug-2019 01:13:29 - Last edited on 20-Aug-2019 03:38:50 by lost ravens

Saito Kuroro

Saito Kuroro

Posts: 3Bronze Posts by user Forum Profile RuneMetrics Profile
I have the same problem, until yesterday the client 1.2.7 worked perfectly but today appeared the text glitch. Today I installed the client 2.2.4 but it runs with lag, with delay, and graphics looks strange, not smooth, with several delay in actions and when, for example, open a window in the game. I tried decreasing the graphic options, selecting for less details and no shadows but the problems continue.

I would wish so Jagex can resolve this bug quickly.

If someone know a option for resolve this problem, I will be grateful.

20-Aug-2019 04:09:41

Pescao6
Aug Member 2007

Pescao6

Posts: 8,254Rune Posts by user Forum Profile RuneMetrics Profile
Press the Windows key + R and type notepad and hit ENTER.
Copy paste the following into Notepad
and then press CTRL+S to save it as deletecache.bat

@echo off
echo Press ENTER to delete the Java and Jagex cache
pause
rd /s /q %HOMEDRIVE%\.jagex_cache_32
rd /s /q %WINDIR%\.jagex_cache_32
rd /s /q %USERPROFILE%\AppData\LocalLow\Sun\Java
rd /s /q %USERPROFILE%\.jagex_cache_32
rd /s /q %USERPROFILE%\jagexcache\jagexlauncher\bin\.jagex_cache_32
rd /s /q %USERPROFILE%\jagexcache\runescape
rd /s /q %USERPROFILE%\jagexcache\oldschool
rd /s /q %USERPROFILE%\jagexcache1
rd /s /q %USERPROFILE%\jagexcache2
rd /s /q %USERPROFILE%\jagexcache\speccollect
del /q %USERPROFILE%\jagex_cl_oldschool_LIVE*.dat
del /q %USERPROFILE%\jagex_cl_runescape_LIVE*.dat
del /q %USERPROFILE%\jagex_cl_runescape_LIVE_BETA*.dat
del /q %USERPROFILE%\jagex_cl_speccollect_LIVE.dat
del /q %USERPROFILE%\jagexappletviewer.preferences
echo Completed succesfully! All existing Java and Jagex cache files were deleted.
pause
exit

Restart your PC to make sure the game files are not being used.
Now right click the deletecache.bat file you made and run it as an administrator.
Once you've received the completed message, try launching the game.

Note: After clearing your cache, you may lag until the cache gets rebuilt to 100%. You can review your cache % by using the
displayfps
command on the Developer Console.

Let me know if this helps. ;)
*
Community Helper
Pescao6
| El Imperio Latino's Owner

20-Aug-2019 17:55:25

Shushannia

Shushannia

Posts: 7Bronze Posts by user Forum Profile RuneMetrics Profile
Done the above work

Yesterday is got jumbled text so loaded 2.2 wotever version, not a very good version, but could read the text, so logged in today and that version has jumbled text.

Not overly keen on messing with the code, unless someone can confirm it works

20-Aug-2019 21:21:41

Saito Kuroro

Saito Kuroro

Posts: 3Bronze Posts by user Forum Profile RuneMetrics Profile
Hello everyone:

In another thread the user Heer Ewout also mentioned this solution:

Changing from DirectX to OpenGL or Safe Mode fixes it.
Can be found here: https://cdn.discordapp.com/attachments/566965479076265995/613322642732089354/unknown.png

It's work for me.

20-Aug-2019 21:28:23

lost ravens
Jun Member 2019

lost ravens

Posts: 861Gold Posts by user Forum Profile RuneMetrics Profile
I've deleted all the cached files I could find, uninstalled all the clients, rebooted pc, and still no results. Until I ran auto-setup and it switched me to OpenGL. OpenGL and Safe Mode seem to be working, safe mode in particular for me. Seems to be a problem with the Directx on the Java client.

20-Aug-2019 21:38:57

Quick find code: 409-410-976-66116973Back to Top