Forums

ETA Bug Found with Skilling!!!

Quick find code: 14-15-286-66118132

Edward Nigma
Jun Member 2019

Edward Nigma

Posts: 21Bronze Posts by user Forum Profile RuneMetrics Profile
On occasion I play two accounts at once. In my last few sessions, I have found skilling timers are inaccurate.

I would craft the same item on two accounts, for example, and it would say 47 seconds until complete for each upon starting the crafting process. However, the account I started crafting with first would occasionally lag behind the second account.

If I started Account 1 first, and Account 2 second, then looked at the timers, they would say Ac1 45 seconds until completion, Ac2 47 seconds until completion, in the progress window. But, Ac2 could finish crafting the item before Ac1, with Ac1 having 5-20 seconds left until finished. That type of disparity shouldn't occur...

If that is consistent across all skilling, I could be losing hours or days of crafting time over the course of my play...

I have noticed more and more, tasks that display 5-10 seconds in the progress window taking far longer than 5-10 seconds. With the number going up, like from 3-4 or 9-10 seconds remaining.

27-Aug-2019 17:45:14

Tranq
Nov
fmod Member
2007

Tranq

Forum Moderator Posts: 59,967Emerald Posts by user Forum Profile RuneMetrics Profile
It could have alot to do with the 6 second tick system. If you started one in say the 12:00:00 tick and the other in the 12:00:06 tick even though they're started at practically the same time could be why there is a lag discrepancy. The other option is due to PID. The lower the player ID number the faster that character reacts, PID changes everytime one logs in. It's how duels are often won at duel arena, by who attacks first with the lower PID. ~Tranq~
Reaping another soul from the ambient mortality
Need Forum Help (click me)

27-Aug-2019 18:21:16

killjoyyzz

killjoyyzz

Posts: 138Iron Posts by user Forum Profile RuneMetrics Profile
could also be the ping as well to the server , it may be one internet connection but it's divided between 2 clients giving them a separate ping , one could delay slightly behind the other and can also cause a visual delay as well making both different no matter if you start both at the exact same time.

29-Aug-2019 01:38:43

Kings Abbot

Kings Abbot

Posts: 4,329Adamant Posts by user Forum Profile RuneMetrics Profile
I thought The Riddler would be smart enough to use bug reports... The Winner of September 2019's MUPAQ™ Award is
Tuffty
! Congratulations!
Do you notice an unhelpful post without it trolling too much? Tell us about it here, it might become the next winner!
I am Groot Gloop!

29-Aug-2019 09:48:32

Edward Nigma
Jun Member 2019

Edward Nigma

Posts: 21Bronze Posts by user Forum Profile RuneMetrics Profile
Tranq said:
It could have alot to do with the 6 second tick system. If you started one in say the 12:00:00 tick and the other in the 12:00:06 tick even though they're started at practically the same time could be why there is a lag discrepancy. The other option is due to PID. The lower the player ID number the faster that character reacts, PID changes everytime one logs in. It's how duels are often won at duel arena, by who attacks first with the lower PID.


So, they deliberately made it so the game would make it more difficult for some players?

I am leaning toward the latter, as one account was consistently slower than the other, even on subsequent logins I have tested.

This is a serious issue that should be addressed :/.

03-Sep-2019 22:15:41

O Pateras
Jun Member 2019

O Pateras

Posts: 984Gold Posts by user Forum Profile RuneMetrics Profile
I noticed this during double xp weekend.

I was fletching protean logs in the most populated world and noticed that the timer for 60 logs would continuously go up after each one.

Come to find out the game ticks were taking twice as long due to server lag. (I used a timer to determine that '3 minutes' took more than 6...)

Double XP at half the rate... So... Par for an hour or two before I figured it out and switched worlds.

After switching to a lower pop world, game ticks were back to normal.


Edit: I have a 100MB/s downlink speed, so this was purely on the server side due to the number of active players.

i.e. it's entirely possible that one of your accounts was logged in to a more populated world than the other, and people don't typically realize that this actually has an impact on their xp rates.

04-Sep-2019 07:19:26 - Last edited on 04-Sep-2019 07:22:28 by O Pateras

Kings Abbot

Kings Abbot

Posts: 4,329Adamant Posts by user Forum Profile RuneMetrics Profile
Edward Nigma said:
Kings Abbot said:
I thought The Riddler would be smart enough to use bug reports...


I couldn't find bug reports. They must have changed the forums from the last time I used them. Could you link it for me?


Bug reports should NEVER be sent via the forums. Use the ingame feature, it’s a red flag somewhere in your chat window.
The Winner of September 2019's MUPAQ™ Award is
Tuffty
! Congratulations!
Do you notice an unhelpful post without it trolling too much? Tell us about it here, it might become the next winner!
I am Groot Gloop!

04-Sep-2019 11:49:36

Quick find code: 14-15-286-66118132Back to Top