Forums

Tears of Guthix (quest) glitch

Quick find code: 14-15-664-66113986

Zach Attackk
Jun Member 2019

Zach Attackk

Posts: 1Bronze Posts by user Forum Profile RuneMetrics Profile
So, I tried starting the Tears of Guthix quest today and I found out I cannot, despite having every requirement to do so. I have the skill reqs, item reqs, and quest point req, I was not holding anything in my hands or had any gear whatsoever

You start the quest by speaking to Juna the snake and telling her a story, but every time I try my character says um... well.. and it says my story does not impress her and it says I need 44 quest points (I have 149) and the completion of Tears of Guthix quest (THATS WHAT IM BLOODY TRYING TO DO). I've tried every chat dialogue option, Ive tried logging in and out nothing is working, I even mined the stone to make the bowl and it says I cant because I havent started the quest. Is there anything I'm missing here?

01-Aug-2019 18:28:05

Kings Abbot

Kings Abbot

Posts: 4,315Adamant Posts by user Forum Profile RuneMetrics Profile
It's a known issue and threads have been made about it already. The Winner of September 2019's MUPAQ™ Award is
Tuffty
! Congratulations!
Do you notice an unhelpful post without it trolling too much? Tell us about it here, it might become the next winner!
I am Groot Gloop!

01-Aug-2019 18:42:49

Quick find code: 14-15-664-66113986Back to Top