Forums

Your device isn't compatible

Quick find code: 443-444-8-66087718

of 2
RONlN
Jan Gold Premier Club Member 2019

RONlN

Posts: 15Bronze Posts by user Forum Profile RuneMetrics Profile
" your device isn't compatible with this version."

Im trying to get rs3 mobile beta. With a phone LG g7 thinq and I have android version 8.0.why is it not letting me download? Please help!

If wrong section. Please move thread. Thank you!

05-Mar-2019 17:41:35

Digitalis
Nov Gold Premier Club Member 2018

Digitalis

Posts: 15Bronze Posts by user Forum Profile RuneMetrics Profile
I can*t even get to the download page, it just says “item not found*. I guess my old Nexus 7 is blocked as being incompatible even though it has 5.1.1.

05-Mar-2019 17:50:00 - Last edited on 05-Mar-2019 17:50:51 by Digitalis

Mr   Candy

Mr   Candy

Posts: 376Silver Posts by user Forum Profile RuneMetrics Profile
They added this line to the FAQ today

An Android device with Android 5.0 or higher - subject to ongoing performance and compatibility improvements, at present, some devices will not be able to install or update to the latest version.
Hang in there iOS users, your turn won't be long now!

:/
If it is not showing on the app store or it says device incompatible. Then the only option you have is to try reserve a place with another device/emulator and patiently wait until they support our devices , if at all

05-Mar-2019 17:55:27

Mod Poerkie

Mod Poerkie

Jagex Moderator Forum Profile Posts by user
Subject to ongoing performance and compatibility improvements (from what I'm told, there are loads of factors that are in play), at present, some devices will not be able to install or update to the latest version; apologies for any inconvenience. We're aiming to increase compatibility moving forward.

This may include devices that meet the requirements specified on the website.
Community Manager! @JagexPoerkie

05-Mar-2019 18:06:55

Petigun

Petigun

Posts: 8Bronze Posts by user Forum Profile RuneMetrics Profile
Mod Poerkie said:
Subject to ongoing performance and compatibility improvements (from what I'm told, there are loads of factors that are in play), at present, some devices will not be able to install or update to the latest version; apologies for any inconvenience. We're aiming to increase compatibility moving forward.

This may include devices that meet the requirements specified on the website.


So basically this means that everyone that thought they had the specs to have the app, and don't, won't be able to even get the chance to use it this time? I mean, this won't be a problem that will be solved until the deadline for the download ends, right?

Meaning, people like me, who were on a break and got memberhip just to try to get into mobile will have money and time wasted...

I know you guys are trying your best, but how can you even call this a "beta" if people can't even access the game, specially when they were suposed to, giving the info we were handed? Making sure your "test subjects" have access to the test in question seems like a BIG priority.

05-Mar-2019 18:28:05 - Last edited on 05-Mar-2019 18:40:21 by Petigun

Eskimootje
Dec Gold Premier Club Member 2017

Eskimootje

Posts: 14Bronze Posts by user Forum Profile RuneMetrics Profile
My Oneplus 3 also meets the technical requirements, but sadly not allowed to download as considered "not compatible"... A lot of work still to be done, it seems ... Back to being patient.

05-Mar-2019 18:31:08

Jake Adex
Apr Gold Premier Club Member 2018

Jake Adex

Posts: 27Bronze Posts by user Forum Profile RuneMetrics Profile
My device was compatible with the app till last freaking week.
Till last week, the only issue we had was that the beta slots were filled.

However when i tried searching for it since today morning however I cant even find it on the playstore without going to it from the rs website link directly, and it says its no longer compatible with my device.

I have other things to do with my time, but I've been constantly checking back frequently for updates on when new beta slots were coming out since the initial 25k slots. We were told it would be released in the upcoming weeks, and it gets released now, half a year later and so I went out of my way to try and get to download it today (Set alarms, and stayed up despite having a 20 hour long drive in less than 2 hours)
and guess what? I can't, because yea, apparently as of less than a week ago, not even a Oneplus 3 can run it anymore, and the worst part?
We weren't told. We went on the presumption that when you say anything over 5.0, you dont mean you'll jack it up suddenly the next day to nothing below android 9.
If we at least knew ahead of time, we could have upgraded our phones for the beta cap release, but nah.


I'm a very annoyed customer rn.

05-Mar-2019 19:05:02

RONlN
Jan Gold Premier Club Member 2019

RONlN

Posts: 15Bronze Posts by user Forum Profile RuneMetrics Profile
I'm a paying premium gold member sir. I've waited for this for so long. Only for my phone to become incompatible is very unacceptable. If I don't have an access to rs3 beta before the limit is capped, I'm going to be very upset and you will hear a lot from me. Please fix this!

05-Mar-2019 20:12:45

Quick find code: 443-444-8-66087718Back to Top