Forums

Spirit trees don't work

Quick find code: 409-410-170-66081632

Immortan Joy
Jan Member 2019

Immortan Joy

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
My members expired today so I renewed and went to do my tree run as I have the past few weeks but the spirit tree at the Grand Exchange didn't have a teleport option any more.

I relogged, made sure I was on a members world, still nothing. I have completed the Gnome Tree Village quest obviously.

I also ran to the gnome stronghold and tried to use the tree there but that also didn't work and I got the message that I have to complete the Grand Tree quest.

Whats going on? The Gnome Tree Village quest still clearly states that it gives access to the spirit tree teleport network.

06-Feb-2019 17:25:43

Asahel Frost
Dec Member 2007

Asahel Frost

Posts: 12,975Opal Posts by user Forum Profile RuneMetrics Profile
Hi Immortan Joy.

Have you tried using the spirit tree in the tree gnome village, which is the system's hub before you complete the Grand Tree quest?

Maybe you have to teleport gnome village -> grand exchange before you can travel the other way.
Glad to be of service :) (Powered by GPP™ - Share and Enjoy!)
Forum Community Helper (info)
Twitter: @JagexHelpFrost
FC: SilverScaper

08-Feb-2019 09:55:53

Quick find code: 409-410-170-66081632Back to Top