Forums

Broken Spring Cleaner

Quick find code: 15-16-999-66082931

of 2
Door Naabe
Oct Gold Premier Club Member 2018

Door Naabe

Posts: 4Bronze Posts by user Forum Profile RuneMetrics Profile
To start, I did set it up correctly and have a spring cleaner9000 on my main ironman account, so I can ensure it was set up correctly.

Made a new spring cleaner after M/S update about a week ago and it has not proc'd even once. I upgraded it to 2000 just to see if that changed something, but nope.

I've tried putting the first page to all RESEARCH (guaranteed roll) as well as switched them to dismantle mode. Upon unlocking 2000 mode, I set up all salvage to alch, and still nothing has proc'd.

I hadn't seen anything on forums or reddit, so I'm not sure if I am the only one, but this is pretty detrimental to the use of the spring cleaner, and I am sure as heck not able to make another one 'just in case' that somehow fixes the bug.

I've already submitted a bug-report in game last week, but again, looking to see if there was something I might be able to do that could fix it.

12-Feb-2019 12:54:57

Ethereal199
Oct Gold Premier Club Member 2015

Ethereal199

Posts: 2,185Mithril Posts by user Forum Profile RuneMetrics Profile
Have you read the RS Wiki article about the Spring Cleaner?

https://runescape.wiki/w/Spring_cleaner

All modes uses at least 1 spring, except disassembly mode. However, you need at least 1 spring left for disassembly mode to activate (provided the Spring Cleaner is 3000 or above).

If it's not working as intended based on the RS Wiki article, then you did the correct thing to submit a bug report. If there is a bug present and you've provided ample reproduction steps to replicate the bug, then it should be fixed in due time.
Hard -> 3a Range Top (#357), 3a Full Helm (#439), Barrows Dye (#1755, #2546)
Elite -> Shadow Dye (#510), Barrows Dye (#680, #1567), 3a Druidic Staff (#969), Sack of Effigies (#972), Ice Dye (#1539)
Master -> Barrows Dye (#480)

12-Feb-2019 13:22:01

Spacemecha1

Spacemecha1

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
ya lil naabe i am having the same issue as well mine wont even a tempt to do anything. also my bone-crusher wont work and my gold accumulator wont work ether sense the new mining and smiting update.

06-May-2019 05:50:17

bacon bit
Jan Gold Premier Club Member 2017

bacon bit

Posts: 92Iron Posts by user Forum Profile RuneMetrics Profile
Spacemecha1 said:
ya lil naabe i am having the same issue as well mine wont even a tempt to do anything. also my bone-crusher wont work and my gold accumulator wont work ether sense the new mining and smiting update.


Check to see if you have lootshare on or maybe if you are in a group. I know that things like bonecrusher and charming imp don't work if lootshare is on.

I've never used spring cleaner so I don't know if it would affect that.

06-May-2019 11:52:01

Xelxius
Sep Member 2011

Xelxius

Posts: 3,958Adamant Posts by user Forum Profile RuneMetrics Profile
Research/Dismantle mode only works on Crafting/Fletching items.

Disassembly mode isn't available until 3k.

Alch mode requires springs and only works on salvage.

And it flat out won't work if you have lootshare enabled. (Lootshare can be found through Friends Chat, I'm pretty sure, and is limited to LS enabled worlds.)

07-May-2019 21:32:35

Toke Chan
Feb Member 2019

Toke Chan

Posts: 36Bronze Posts by user Forum Profile RuneMetrics Profile
I have the same problem, just invented my spring cleaner 2000 and I added some springs (200) but it doesn't work, when I try to check charges it says "you have not configured your spring cleaner yet", I selected all the items that I want to be used for high alchemy or dismantle and research, but is not working or being configured. Also my gold accumulator is not working while I have in my inventory the spring cleaner. Please I need help to solve this issue.

14-Jun-2019 06:07:13

criticalm4ss
Sep Member 2017

criticalm4ss

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
yeah exact same problem here. super bummed out that i spent many mills on springs only to have the thing not work whatsoever. just says i have not configured it when i go to check charges even though i definitely do have it configured. super frustrating

17-Aug-2019 06:50:20

Quick find code: 15-16-999-66082931Back to Top