Forums

Icthlarin's Little helper bug

Quick find code: 20-21-404-65862696

of 2
Virve

Virve

Posts: 6Bronze Posts by user Forum Profile RuneMetrics Profile
There is a bug for this quest. I have all the requirements (including the kitten/cat) but when I talk to the wanderer the conversation ends after I ask why she's so afraid of cats. She just tells me to quickly put it away and then the dialogue ends. If i talk to her again it just starts it all over again. No other dialogue option helps, and picking up the cat when she says to just resets the conversation. What up with that ? :(

22-Dec-2016 23:20:28

Asahel Frost
Dec Member 2007

Asahel Frost

Posts: 11,636Opal Posts by user Forum Profile RuneMetrics Profile
Hi Virve.

Runemetrics says that you aren't eligible for Icthlarin's Little Helper. You need to complete Stolen Hearts and Diamond in the Rough. These two quests replaced Prince Ali Rescue, but even if you completed the older quest, you need to complete the new ones before you can start Icthlarin's Little Helper.
Glad to be of service :) (Powered by GPP™ - Share and Enjoy!)
Forum Community Helper (info)
Twitter: @JagexHelpFrost
FC: SilverScaper

22-Dec-2016 23:52:41 - Last edited on 22-Dec-2016 23:56:27 by Asahel Frost

Naebawerm8

Naebawerm8

Posts: 2Bronze Posts by user Forum Profile RuneMetrics Profile
I'm also having a problem with this quest at the part where you are meant to jump the pit to get out of the flashback after picking up the jar. I jump the pit but the flashback doesn't end, I have tried walking out and back into the pyramid but that doesn't seem to solve anything. Any help would be great since I'm not no longer able to progress in this quest at all.

03-Oct-2017 17:49:59

Justin831
Sep Gold Premier Club Member 2017

Justin831

Posts: 5Bronze Posts by user Forum Profile RuneMetrics Profile
I'm having an issue with this quest as well. I have all of the required items, as well as all pre-req quests completed. When I talk to the wanderer initially, I choose the second chat option and and he tells me to get the cat away from him, and finish the conversation with him. But I am unable to pick up my cat. I've tried relogging, I've dismissed forever and picked up a new cat from Gertrude, I've tried talking to the wanderer with the cat summoned and without. I can't pick up the cat in other cities either. Once the cat is summoned, my only option is to lose it forever.

Am I missing something?

**EDIT** Went back down and tried again and everything worked just fine. Must have just been a mistake on my part or maybe a game glitch.

09-Oct-2017 20:05:49 - Last edited on 09-Oct-2017 22:16:55 by Justin831

Dark Elf 134

Dark Elf 134

Posts: 33Bronze Posts by user Forum Profile RuneMetrics Profile
I'm also having an issue with this quest. I'm on the second flashback where you have to get one of the jars. I was able to pick up the intestinal jar at first, but then I another issue with connecting to the game logged me out and put me in a non-member world. Ever since then if i go back in, it keeps telling me I have to get the jar for the mistress but there is no intestinal jar to be found, there are only 3 in the room. Kinda can't continue without it.

27-Nov-2017 08:21:23

Tkdcogwirrel

Tkdcogwirrel

Posts: 67Iron Posts by user Forum Profile RuneMetrics Profile
I am having an issue with this quest. I have not been able to generate a flash back.

The wander does not exist.

I completed The required quests to start Icthlarin's Little Helper. Then went to the wander but they were not there. I looked at the progression of the quest, and it says the shin* says to speak to high preist, but I dont have the token.

Everyone says to speak to the shin* to get anotherone, but I dont get the option.

I havent completed the flash back, when I click on the Pyrimid door, it just says locked. I speak to the ghost and get one word slants but nothing else. I have the jar in my inventry, but cant seem to move forward at all..

15-Feb-2018 22:08:04

Brightside95
Aug Member 2018

Brightside95

Posts: 3Bronze Posts by user Forum Profile RuneMetrics Profile
Hello

After i took the jar and jumped over the egde and got out of the flash back i teleported out of there, not knowing that i couldent return. now i am stuck outside the gates with the guards saying no one is premitted to enter or leave.

Does any of u have some suggestions ?

01-Apr-2018 04:59:53

Quick find code: 20-21-404-65862696Back to Top