Forums

Community: Linux Support 2.0Thread is sticky

Quick find code: 409-410-916-65990459

of 30
HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
Below is the original post made by Mod Tyran in the original thread, this thread has been remade as i have resigned as a forum moderator and i needed to keep the ability to edit my posts after my resignation as a forum mod.

As i am quite busy in real life, if anything needs to be added or updated here, please just give me a tweet on Twitter, my handle is
@TheHikariKnight


--------
Welcome to the Community Linux section of the Technical Support Forums! This area is headed up by our dedicated Linux community.

Please note: Jagex is not responsible for the content within this thread, players following advice held within do so at their own risk.

Contents:
1: Introduction
2: The Beginner Corner
3: Getting the RuneScape JAVA Client to work on Linux
4: Using 32bit Java on a 64bit Linux system
5: Java7/OpenJDK7 and OpenGL
6: Issues with RuneScape on Linux
7: The best way to install the RuneScape NXT client (AMD, Intel and Nvidia)
8: Isolated docker image for use with x11docker
--------
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:17:59 - Last edited on 03-Jan-2019 23:40:41 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
Hello everyone!
This is a recreation of Makoto D's "Community - Linux" thread.

The aim with this thread is to provide the Linux community a place to chitchat and get support for their RuneScape issues, since Jagex do not officially support Linux there is no official place for our community to get support.

This is where this thread comes in, this is our own support and discussion thread!
Our own community consists of several knowledgeable people willing to help you with your RuneScape issues in Linux or your General Linux issues, we do not have the answers to everything but we will at least do our best to help you solve your issues! :)

Before officially opening this new thread i want to thank everyone for 6 fantastic years in the RuneScape Linux Community and i hope we will keep on discussing like we did in the old thread for several new years while i manage this thread :)
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:05 - Last edited on 21-Feb-2018 10:25:19 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ The Beginner Corner ~

We have several resources available for those interested in Linux or wanting to play
RuneScape in Linux, or just try Linux and see how it is. :P

______________

Getting started with Linux:
http://lifehacker.co­m/5778882/getting-started-with-linux-the-complete-guide


The tech blog lifehacker have a good article consisting of 5 lessons for starting with Linux (more precisely Ubuntu Linux), if you are an absolute beginner in Linux and want to try it out you can read their article and start using Linux with minimal effort.
______________

8 Deadly Commands You Should NEVER Run:
http://www.howtogeek.co­m/125157/8-deadly-commands-you-should-never-run-on-linux/


Another tech blog named howtogeek have made an article about the 8 commands you should NEVER run on a Linux/Unix platform while explaining why you should not run them. If you see anyone post something similar then please highlight their post!

_______________

The Linux Directory Structure:
http://www.howtogeek.co­m/117435/htg-explains-the-linux-directory-structure-explained/


Another article from howtogeek, this one explains the directory structure used in Linux and most Unix platforms. Reading this article is recommended if you want to learn where things are stored on the system(unlike windows which dumps everything into 1 folder, Linux and other platforms organize everything in a different way).
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:18 - Last edited on 21-Feb-2018 10:25:44 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Getting the RuneScape JAVA Client to work on Linux ~
For the NXT client go to post 7!
RuneScape has it's own COMMUNITY supported Linux client that was available from the RuneScape download page before NXT, it was made possible by Ethoxyethaan, me and the rest of the RuneScape Community.

The RuneScape Unix Client (RSU-Client for reference) is the easiest way to get RuneScape up and running on your Linux system, it also gives you easy access to the news, oldschool, RuneScape3, FunOrb, client settings!

You could find the link to the RSU-Client on the RuneScape download page in the past.
However this has now been moved over to github as NXT has been released (which is not related).
https://github.co­m/rsu-client/rsu-client/releases


The client is OpenSource and licensed under GPLv2
__________

~ RuneScape in the Linux browser (historical) ~
For those that prefer the browser, I made a perl script to fix the OpenGL issue with Java. You can get it by downloading this archive:
Original message details are unavailable.
~link no longer available~


extract the archive file and then run the java-wrapper file inside the terminal like this (make sure you cd to the same folder as the java-wrapper script first!)
Original message details are unavailable.
sudo ./java-wrapper --install


then follow the instructions on the screen, you will have to do this for every java update though as it replaces the java binary with this script and then adds a few parameters to the binary when launched.

This is however not a recommended way to run RuneScape on Linux due to the lack of a user friendly way to debug issues with this method.

If you want to uninstall the wrapper you can launch it with the --uninstall parameter instead of --install

For installing the Java plugin please refer to this tutorial video
http://youtube.co­m/watch?v=Be7Cz8HZTcU


For a visual guide on installing the java-wrapper please look at this video
http://www.youtube.co­m/watch?v=NRhR3o7TFEw
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:22 - Last edited on 03-Jan-2019 23:41:43 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Using 32bit Java on a 64bit Linux system ~
Make sure you have the 32bit libraries installed, follow the steps for your system below.

Debian:
su
apt-get install ia32-libs

Ubuntu(and other *ubuntu versions) and LinuxMint(or similar forks of ubuntu):
sudo apt-get install ia32-libs

Fedora:
N/A - please provide command

Suse/OpenSuse:
N/A - please provide command

ArchLinux:
Follow the instructions on the ArchLinux wiki
https://wiki.archlinux.or­g/index.php/Multilib

then run "pacman -Syy" in the Terminal to refresh the packages database
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:25 - Last edited on 21-Feb-2018 10:29:19 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Java7/OpenJDK7+newer and OpenGL (in detail) ~
Java7 and OpenJDK7(on most distributions) and newer are not compiled correctly and fails to find their own libraries which are needed for the OpenGL and Software display modes in RuneScape.

This can be hotfixed by applying
Original message details are unavailable.
LD_LIBRARY_PATH=/path/to/java/lib

directly on the java executable.
The RSU Client and java-wrapper does this automatically so you don't have to worry about it! :D

~ RuneScape and Nvidia Optimus ~
Currently optirun does not work on runescape, neither directly on the java command or the client script.
Errorlogs indicate that it is caused by libGL.so
Using primusrun however seems to fix the issue, currently only the RSU-Client supports primusrun by activating the option in the settings menu under the "script settings" tab.

~ OpenSource graphic drivers and OpenGL ~
OpenSource drivers often lack proper 3d hardware acceleration.
Please use the proprietary graphic drivers instead for the best performance!

~ The black bars will not go away ~
Find a way to download Java7 and extract it somewhere then have the RSU client use the java binary from that to launch the game.
Due to unmaintained code on Jagex end the black bars being removed may not work on newer java versions.

NOTE: Due to copyright i can not provide a download for java7 if oracle has locked it away to only be accessible to paying customers.
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:32 - Last edited on 21-Feb-2018 10:29:48 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Issues with RuneScape Unix Client (NOT NXT) on Linux ~
Make an issue on github and i will have a look at it if i have some spare time (as development is slow right now but it works and is very stable)
https://github.com/rsu-client/rsu-client/issues



~ GPG key invalid for RuneScape NXT repository ~
To go around this, edit /etc/apt/sources.list.d/runescape.list to look like:
deb [trusted=yes] https://content.runescape.com/downloads/ubuntu trusty non-free

~ Cannot install the RuneScape NXT client due to missing libraries in Ubuntu ~
run this command in the terminal to install the right version of libglew
Original message details are unavailable.
wget http://launchpadlibrarian.net/161405671/libglew1.10_1.10.0-3_amd64.deb
sudo dpkg -i libglew1.10_1.10.0-3_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb


To go around this, edit /etc/apt/sources.list.d/runescape.list to look like:

deb [trusted=yes] https://content.runescape.com/downloads/ubuntu trusty non-free
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:36 - Last edited on 08-Mar-2018 00:40:08 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ The best way to install the RuneScape NXT client ~
We have some really amazing community members that have developed a flatpak install for the NXT client.
Say what you want about snaps vs flatpaks, one is better than the other in different tasks and in this case flatpaks are more flexible.
Here is the list of contributers to the flatpak image: https://github.com/flathub/com.jagex.RuneScape/graphs/contributors/

I have also audited the source (finally) in Christmas 2018 and can verify it is safe to use.
Q: Why use a flatpak over native install?
A: The runescape-launcher package relies on libpng12 which has security issues, and it relies on older versions of packages no longer available and you open your system up for security and stability issues by cross installing those from older distributions.
A2: It works on any distribution that supports flatpaks!

1. Install flatpak and the flathub repository: https://flatpak.org/setup/
2. Install the client using the command below
Original message details are unavailable.
flatpak install flathub com.jagex.RuneScape

or through here (but may fail if your software manager has not restarted yet hence why i put the command first)
https://flathub.org/apps/details/com.jagex.RuneScape

3. If you are using an Nvidia Graphics Card you need to do some more work, so keep reading!

n1. Find your exact driver version
For driver version 390 and newer
Original message details are unavailable.
apt-cache policy nvidia-driver-*


For driver versions older than 390
Original message details are unavailable.
apt-cache policy nvidia-3*


look at the ''Installed:'' part and note down the XXX.YY numbers, for this guides example it is 390.48

n2. See if flathub has an nvidia package for your driver
Original message details are unavailable.
flatpak remote-ls flathub | grep nvidia


n3. Install the 32bit and 64bit runtime for our driver (replace 390-48 with your version)
Original message details are unavailable.
flatpak install flathub org.freedesktop.Platform.GL.nvidia-390-48
flatpak install flathub org.freedesktop.Platform.GL32.nvidia-390-48
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:44 - Last edited on 03-Jan-2019 23:11:57 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Isolated docker image for use with x11docker ~
This is a work in progress but feel free to use it if you are familiar with docker (native, the snap version will most likely not work)
requires you to install x11docker: https://github.com/mviereck/x11docker
also requires ''docker-ce kwin-wayland xwayland xrandr weston xdpyinfo unzip xterm''

To install docker go here: https://docs.docker.com/install/linux/docker-ce/ubuntu/
If you have 18.10 then use the test repository instead of the release repository, as there is currently no stable release for 18.10

Image size, no browser: 554mb
Image size, firefox included(default): 780mb
why firefox over chromium? firefox was 100mb smaller

Note: run the below command on your biggest resolution monitor (move the terminal to that screen before executing) as that resolution is what will be the max resolution inside the isolated x11/Xwayland window.

You can run the docker isolated client with these commands
Original message details are unavailable.
mkdir ~/.runescape-nxt
x11docker --weston-xwayland --wm='kwin' --gpu --pulseaudio --homedir="$HOME/.runescape-nxt/" -- -- hikariknight/runescape-nxt


To run the smaller image with no browser included use
Original message details are unavailable.
mkdir ~/.runescape-nxt
x11docker --weston-xwayland --wm='kwin' --gpu --pulseaudio --homedir="$HOME/.runescape-nxt/" -- -- hikariknight/runescape-nxt:core


answer yes to download the image
if you ever want to update the image just run (if you want to update the non browser version add '':core'' a the end)
Original message details are unavailable.
docker pull hikariknight/runescape-nxt


Full Dockerfile and more info available at
https://hub.docker.com/r/hikariknight/runescape-nxt
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:45 - Last edited on 03-Jan-2019 23:36:50 by HikariKnight

HikariKnight

HikariKnight

Posts: 6,837Rune Posts by user Forum Profile RuneMetrics Profile
~ Intel Graphics Issues with NXT ~
Note: this is for the flatpak version

Espionage724 found a way to fix NXT on their Intel GM45 Graphics using this command
different mesa version overrides might work for different intel graphics
Original message details are unavailable.
flatpak run --env='MESA_GLSL_VERSION_OVERRIDE=450' com.jagex.RuneScape


they also found out that you can get some debug info in relation to OpenGL from the NXT client so you might be able to get an idea as to why NXT wont work by passing MESA_DEBUG=1 LIBGL_DEBUG=verbose to the client
Original message details are unavailable.
flatpak run --env='MESA_DEBUG=1' --env='LIBGL_DEBUG=verbose' com.jagex.RuneScape


~ Links to other posts with useful info ~
Copy the numbers and replace whats after "forum.ws?" in the forum url with the new numbers.
* Intel Graphics with NXT and MSAA + other stuff: 409,410,916,65990459,164,344171222,#163
* NXT client as a snap: 409,410,916,65990459,goto,18#171
God/Protector of the Penguins.
Developer of the RuneScape Unix Client.
Maintainer of the Linux Tech Support thread

21-Feb-2018 10:18:50 - Last edited on 05-Apr-2019 15:23:48 by HikariKnight

Quick find code: 409-410-916-65990459Back to Top